Firesheep : l’extension de Firefox qui détourne vos données sur Wi-Fi

En créant Firesheep, un développeur a dévoilé les lacunes des sites et des services web en matière de sécurité et de confidentialité. En l’installant sur votre ordinateur, ce plug-in peut mettre la main sur les données de connexion requises pour pirater les sessions web d’autres internautes sur des réseaux Wi-Fi non sécurisés.

Firesheep donne ainsi accès aux sessions non chiffrées du protocole http permettant aux utilisateurs de ce segment de réseaux d’avoir un accès aux réseaux sociaux, aux services en ligne et à tout autre site web exigeant un identifiant. Les sites concernés sont Facebook, Twitter, Flickr, Google, Amazon, Yahoo, WordPress, etc.

«Aussitôt qu’une personne sur le réseau visite un site web non sécurisé connu de Firesheep, son nom et ses photos seront affichés», explique Eric Butler, le développeur à l’origine de l’extension. Une personne malveillante n’a qu’à double cliquer sur l’identifiant d’un internaute pour s’approprier son identité sur plusieurs sites web. «Lorsqu’on parle de la sécurité informatique des usagers, SSL est l’éléphant dans un magasin de verre», poursuit-il.

L’extension se présente sous forme de panneau latéral dans Firefox, affiche l’avatar et le nom des gens qui se font « attraper ». En double cliquant sur cet avatar, vous êtes alors automatiquement loggé sur le compte de la personne, et vous pouvez accéder à ses informations personnelles. Rien de vraiment nouveau dans cette technique de sniffing, si ce n’est que maintenant c’est à la portée de n’importe qui.

En concevant cette extension, son développeur souhaitait pousser à la sécurisation d’Internet, en démontrant ainsi que la protection des internautes utilisant des sites non sécurisés n’était pas assurée par ces derniers.

Firesheep a été téléchargé plus de 30 000 fois, mais ce chiffre augmente très vite. L’extension est compatible avec Windows, Mac OS X et une version pour Linux est en développement. En attendant que tous ces sites corrigent cette faille, il est possible de télécharger l’extension Firefox Force-TLS, qui force l’utilisation du protocole HTTPS.

Partager : Facebook Twitter Plusone

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *


*