Un bug du langage PHP « plante » des serveurs Web

Le problème signalé est susceptible d’empêcher les systèmes 32 bits exécutant du PHP de servir des pages Web. Le bug expose les systèmes PHP (très utilisés dans le développement Web) à une attaque DDOS exploitable à distance et serait lié à un problème de virgule flottante, touchant les systèmes Linux et Windows.

La faille résulte d’un défaut de conception du chipset x87 intégré à une ancienne version du processeur Intel X86, dont les compilateurs ne savent pas traiter un problème spécifique de virgule flottante. Ce bug, lié à une mauvaise conception du hardware, ne devrait théoriquement pas affecter les systèmes PHP de grande capacité puisqu’ils tournent en 64-bits.

Les développeurs pourront proposer très vite une solution de contournement propre à chaque version PHP, provisoirement appelées PHP 5.3.5 et PHP 5.2.17. Cette solution devrait intervenir en l’espace de quelques heures.

Partager : Facebook Twitter Plusone

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*